從EF Core 1.1升級到2.0預覽版

entity-framework-core

將EF1.1升級到EF2.0後,我無法進行遷移。

錯誤:啟動項目'QilinSystem.Store.Data.csproj'以框架'.NETStandard'為目標。此框架不用於執行,可能無法解決運行時依賴性。如果是這樣,請使用--s tartup-project選項指定其他項目,然後重試。

如何解決這個問題?

熱門答案

EF Core 2.0 Preview 1需要Visual Studio 15.3預覽版,因此您必須安裝它。

宣布EF Core 2.0預覽1

在Visual Studio中訪問.NET Core工具需要Visual Studio 2017 15.3預覽版,Visual Studio for Mac版或Visual Studio代碼版。有關此內容和下載鏈接的更多信息,請參閱.NET Core 2.0 Preview 1公告。

Visual Studio預覽常見問題

預覽安裝在穩定的Visual Studio IDE旁邊,允許您獨立使用。



Related

許可下: CC-BY-SA with attribution
不隸屬於 Stack Overflow
許可下: CC-BY-SA with attribution
不隸屬於 Stack Overflow