Facing Issue while Installing dotnet-ef with netcoreapp3.0

.net-core c# entity-framework entity-framework-core netcoreapp3.0

Question

I am trying to use EF core Migration features. But when I install dotnet-ef tools from NuGet, below error message is thrown. My app version is netcoreapp3.0.

dotnet tool install --global dotnet-ef --version 3.1.0-preview3.19554.8

error NU1202: Package dotnet-ef 3.1.0-preview3.19554.8 is not compatible with netcoreapp3.0 (.NETCoreApp,Version=v3.0) / any. Package dotnet-ef 3.1.0-preview3.19554.8 supports: netcoreapp3.1 (.NETCoreApp,Version=v3.1) / any

Older version only support netcoreapp2.1

dotnet tool install --global dotnet-ef --version 3.0.1

error NU1202: Package dotnet-ef 3.0.1 is not compatible with netcoreapp3.0 (.NETCoreApp,Version=v3.0) / any. Package dotnet-ef 3.0.1 supports: netcoreapp2.1 (.NETCoreApp,Version=v2.1)

Actually which dotnet-ef version is supporting netcoreapp3.0 Any idea?

1
5
12/7/2019 3:53:02 PM

Popular Answer

This works for me on November 2019

dotnet tool install --global dotnet-ef --version 3.0.0
12
12/4/2019 8:07:52 PM


Related Questions





Related

Licensed under: CC-BY-SA with attribution
Not affiliated with Stack Overflow
Licensed under: CC-BY-SA with attribution
Not affiliated with Stack Overflow