.NET Core 2 on azure portal

.net-core-2.0 c# entity-framework-core sql-server

Question

Is there a setting on the azure portal to run .NET Core 2? I migrated our code base to run on .NET Core 2 from .NET Core 1.1.4. However, on the portal, I only see options to select .NET Framework v3.5 and v4.7

Command: "D:\home\site\deployments\tools\deploy.cmd" Handling ASP.NET Core Web Application deployment. D:\Program Files (x86)\dotnet\sdk\2.1.300-rc1-008673\Sdks\Microsoft.NET.Sdk\targets\Microsoft.NET.ObsoleteReferences.targets(33,5): warning : Using DotNetCliToolReference to reference 'Microsoft.EntityFrameworkCore.Tools.DotNet' is obsolete and can be removed from this project. This tool is bundled by default in the .NET Core SDK. [D:\local\repository\TFA\TFA.csproj] D:\Program Files (x86)\dotnet\sdk\2.1.300-rc1-008673\Sdks\Microsoft.NET.Sdk\targets\Microsoft.NET.ObsoleteReferences.targets(33,5): warning : Using DotNetCliToolReference to reference 'Microsoft.Extensions.SecretManager.Tools' is obsolete and can be removed from this project. This tool is bundled by default in the .NET Core SDK. [D:\local\repository\TFA\TFA.csproj] Restore completed in 763.12 ms for D:\local\repository\TFA\TFA.csproj. Restoring packages for D:\local\repository\TFTests\TFTests.csproj... D:\local\repository\TFTests\TFTests.csproj : warning NU1603: Faker.NETCore 1.0.1 depends on NETStandard.Library (>= 1.4.0) but NETStandard.Library 1.4.0 was not found. An approximate best match of NETStandard.Library 1.6.0 was resolved. [D:\local\repository\TF.sln] D:\local\repository\TFTests\TFTests.csproj : error NU1201: Project TFA is not compatible with netcoreapp1.1 (.NETCoreApp,Version=v1.1). Project TFA supports: netcoreapp2.0 (.NETCoreApp,Version=v2.0) [D:\local\repository\TF.sln] Restore failed in 6.14 sec for D:\local\repository\TFTests\TFTests.csproj. Restore completed in 113.64 ms for D:\local\repository\TFA\TFA.csproj. Failed exitCode=1, command=dotnet restore "D:\local\repository\TF.sln" An error has occurred during web site deployment. \r\nD:\Program Files (x86)\SiteExtensions\Kudu\73.10510.3399\bin\Scripts\starter.cmd "D:\home\site\deployments\tools\deploy.cmd"

I found another stackOverflow post that says I have to delete my wwwroot directory before deploying due some possible net1.1 lingering files. I'm going to try that next

EDIT: The deployment seems to be failing because of Faker.NETCore. However, I have no idea what this is. It's not being used anywhere in our app. Is this a lingering library from .NET Core 1.1

1
1
5/30/2018 1:08:10 AM

Popular Answer

I found the issue. It was my testSuite failing. I had to bring that up to 2.0 as well. I'm not sure if delete the deployment cache in tools through the kudo console or wiping out my wwwroot folder helped. But I also did that because of other posts.

0
5/30/2018 7:23:06 PM


Related Questions





Related

Licensed under: CC-BY-SA with attribution
Not affiliated with Stack Overflow
Licensed under: CC-BY-SA with attribution
Not affiliated with Stack Overflow