Package 'Microsoft.EntityFrameworkCore.SqlServer' is incompatible with 'all' frameworks in the project

.net entity-framework-core sql-server

Question

I was trying to add the package named Microsoft.EntityFrameworkCore.SqlServer by running the command.

dotnet add package Microsoft.EntityFrameworkCore.SqlServer

in Visual Studio Code, but I get this error:

Package Microsoft.EntityFrameworkCore.SqlServer 2.0.0 is not compatible with netcoreapp1.1 (.NETCoreApp,Version=v1.1). Package Microsoft.EntityFrameworkCore.SqlServer 2.0.0 supports: netstandard2.0" (.NETStandard,Version=v2.0). Package 'Microsoft.EntityFrameworkCore.SqlServer' is incompatible with 'all' frameworks in project 'C:\users\username..'

1
6
8/16/2017 7:17:03 AM

Popular Answer

I was using version 1.1. Try to run the below command including the version number:

Visual Studio Code:

'dotnet add package Microsoft.EntityFrameworkCore.SqlServer -v 1.1.1'

Visual Studio:-

'Install-Package Microsoft.EntityFrameworkCore.SqlServer -v 1.1.1'

10
8/18/2017 4:00:58 AM


Related Questions





Related

Licensed under: CC-BY-SA with attribution
Not affiliated with Stack Overflow
Licensed under: CC-BY-SA with attribution
Not affiliated with Stack Overflow