Upgrade from EF Core 1.1 to 2.0 preview

entity-framework-core

Question

After upgrading EF1.1 to EF2.0 now I'm not able to do migrations.

Error: Startup project 'QilinSystem.Store.Data.csproj' targets framework '.NETStandard'. This framework is not intended for execution and may fail to resolve runtime dependencies. If so, specify a different project using the --s tartup-project option and try again.

How to solve this issue?

1
0
5/29/2017 3:38:02 PM

Popular Answer

EF Core 2.0 Preview 1 requires Visual Studio 15.3 Preview, so you have to install it.

Announcing EF Core 2.0 Preview 1:

Accessing .NET Core tooling in Visual Studio requires Visual Studio 2017 15.3 Preview, Visual Studio for Mac or Visual Studio Code. More information about this and download links can be found in the .NET Core 2.0 Preview 1 announcement.

Visual Studio Preview FAQ:

Preview installs next to your stable Visual Studio IDE, allowing you to use either independently.

0
5/29/2017 7:53:43 PM


Related Questions





Related

Licensed under: CC-BY-SA with attribution
Not affiliated with Stack Overflow
Licensed under: CC-BY-SA with attribution
Not affiliated with Stack Overflow