Unable to install MySql.Data.EntityFrameworkCore into .NET Core App

asp.net-core entity-framework-core

Question

When trying to install the 'MySql.Data.EntityFrameworkCore' package, I get the following error:

Microsoft (R) Build Engine version 15.1.548.43366 Copyright (C)

Microsoft Corporation. All rights reserved.

Writing /tmp/tmpiXrULm.tmp info : Adding PackageReference for package 'MySql.Data.EntityFrameworkCore' into project '/media/xxx/xxx.csproj'. log : Restoring packages for /media/xxx/xxx.csproj... info : CACHE https://api.nuget.org/v3-flatcontainer/mysql.data.entityframeworkcore/index.json error: Unable to resolve 'MySql.Data.EntityFrameworkCore' for '.NETCoreApp,Version=v1.1'. error: Package 'MySql.Data.EntityFrameworkCore' is incompatible with 'all' frameworks in project '/media/xxx/xxx.csproj'.

I'm targeting Asp.NetCore 1.1.1

Is this the correct MySql EF package for .NET core?

1
0
5/18/2017 10:40:42 PM

Popular Answer

Install given nuget package using package manager console:

Install-Package MySql.Data.EntityFrameworkCore -Version 8.0.9-dmr

OR

Using .NET CLI:

dotnet add package MySql.Data.EntityFrameworkCore --version 8.0.9-dmr

Then add this to .csproj file and restore your project:

<PackageReference Include="MySql.Data.EntityFrameworkCore" Version="8.0.8-dmr" />

0
9/29/2017 11:50:13 AM


Related Questions





Related

Licensed under: CC-BY-SA with attribution
Not affiliated with Stack Overflow
Licensed under: CC-BY-SA with attribution
Not affiliated with Stack Overflow