dotnet exec needs a managed .dll or .exe extension while adding Entity Framework Core (1.1.0) Migrations

asp.net-core-mvc c# entity-framework-core visual-studio-2017

Question

Error Message:

PM> Add-Migration InitialDatabase
dotnet exec needs a managed .dll or .exe extension. The application specified was 'C:\Users\xxxxxx\documents\visual studio 2017\Projects\TheWorld\src\TheWorld\bin\Debug\netcoreapp1.0\TheWorld.runtimeconfig.json'
Process finished with non-zero exit code
PM> 

Visual Studio Version: 2017 RC

Project Dependencies :

Project Dependencies

Error Screenshot : Error Screenshot

1
3
12/21/2016 7:11:21 AM

Accepted Answer

I had the same problem. The only thing I had to do is changing the Target Framework in the Project properties.

Changing the framework version

I hope this helps.

6
12/28/2016 10:52:46 AM

Popular Answer

In VS2017RC - All I had to do was install .NetCore again using Package Manager Console:

Install-Package Microsoft.NETCore.App

Later migration script worked and "dotnet exec needs a managed .dll or .exe extension." error went away.



Related Questions





Related

Licensed under: CC-BY-SA with attribution
Not affiliated with Stack Overflow
Licensed under: CC-BY-SA with attribution
Not affiliated with Stack Overflow