Why can't EntityFramework.Core be added to a simple PCL?

entity-framework-core portable-class-library

Question

Am I missing something obvious?

  1. Open Visual Studio 2015 Update 2
  2. Add a new Portable Class Library project, targeting .NET 4.6 and UWP 10
  3. Attempt to install NuGet package Microsoft.EntityFrameworkCore v1.0.0-rc2-final

It fails with "EntityFramework.Core 7.0.0-rc1-final is not compatible with .NETPlatform,Version=v5.0."

Is this supposed to work?

EDIT

Just to clarify, here is my PCL properties: enter image description here

1
0
5/31/2016 1:33:32 PM

Popular Answer

Installation with nuget unfortunately does not working out of the box. You have to modify the project.json by your self to get it working!

https://docs.efproject.net/en/latest/miscellaneous/rc1-rc2-upgrade.html

"tools": { "Microsoft.EntityFrameworkCore.Tools": { "version": "1.0.0-preview1-final", "imports": [ "portable-net45+win8+dnxcore50", "portable-net45+win8" ] } }

For more info : Trying to install EF Core with Portable Class Library targeting .Net 4.6.1

0
5/23/2017 10:34:01 AM


Related Questions





Related

Licensed under: CC-BY-SA with attribution
Not affiliated with Stack Overflow
Licensed under: CC-BY-SA with attribution
Not affiliated with Stack Overflow