BreezeJS and Entity Framework 6.0.1

breeze entity-framework entity-framework-6

Question

The default MVC/Web API project template that comes with Visual Studio 2013 is what I'm trying to use to construct a Breeze Web API controller, and I'm wondering if that's possible. Entity Framework 6.0.1 is installed by updating everything using the Nuget packet manager. After that, attempting to install Breeze fails because it tries to install EF 5 as a dependency, which is impossible because other components of the template depend on EF6. Do we have to wait for Breeze to release a new version that is compatible with EF6?

I wish to carry out this task using [BreezeController] and Odata in the "breeze way."

1
1
10/17/2013 4:36:44 PM

Accepted Answer

ZZZ_tmp
2
10/29/2013 11:02:26 PM

Popular Answer

Just wanted to mention that the MVC 5 upgrades made available today with VS2013 also break breeze even without EF6.1. It's challenging to separate the components in order to identify the new component at fault. It might be the new odata or MVC. Anyhow, we are eagerly awaiting the updated edition.



Related Questions





Related

Licensed under: CC-BY-SA with attribution
Not affiliated with Stack Overflow
Licensed under: CC-BY-SA with attribution
Not affiliated with Stack Overflow