v1.1へのアップグレード後にASP.NETコアがIISで実行されない

asp.net asp.net-core c# entity-framework-core iis

質問

私はasp.netコアの新しいv1.1を使用するために私のproject.jsonをアップグレードしました。そして今、私がデバッグするためにIIS Expressを起動しようとすると、私は次のエラーを受け取ります:

プログラム '[8784] dotnet.exe'はコード-2147450749(0x80008083)で終了しました。

プログラム '[7352] iisexpress.exe'がコード0(0x0)で終了しました。

私のアップグレードされたproject.json:

"dependencies": {
    "Microsoft.NETCore.App": {
      "version": "1.1.0",
      "type": "platform"
    },
    "Microsoft.ApplicationInsights.AspNetCore": "1.0.0",
    "Microsoft.AspNetCore.Mvc": "1.1.0",
    "Microsoft.AspNetCore.Routing": "1.1.0",
    "Microsoft.AspNetCore.Server.IISIntegration": "1.1.0",
    "Microsoft.AspNetCore.Server.Kestrel": "1.1.0",
    "Microsoft.Extensions.Configuration.EnvironmentVariables": "1.1.0",
    "Microsoft.Extensions.Configuration.FileExtensions": "1.1.0",
    "Microsoft.Extensions.Configuration.Json": "1.1.0",
    "Microsoft.Extensions.Logging": "1.1.0",
    "Microsoft.Extensions.Logging.Console": "1.1.0",
    "Microsoft.Extensions.Logging.Debug": "1.1.0",
    "Microsoft.Extensions.Options.ConfigurationExtensions": "1.1.0",
    "Microsoft.IdentityModel.Tokens": "5.1.0",
    "Microsoft.AspNetCore.Authentication": "1.1.0",
    "Microsoft.AspNetCore.Authentication.JwtBearer": "1.1.0",
    "Microsoft.AspNetCore.Authentication.Cookies": "1.1.0",
    "Microsoft.AspNetCore.Identity.EntityFrameworkCore": "1.1.0",
    "Microsoft.EntityFrameworkCore": "1.1.0",
    "Microsoft.EntityFrameworkCore.Tools": "1.0.0-preview2-final",
    "SapientGuardian.EntityFrameworkCore.MySql": "7.1.10",
    "AutoMapper": "5.1.1"
  },

  "tools": {
    "Microsoft.AspNetCore.Server.IISIntegration.Tools": "1.0.0-preview4-final"
  },

  "frameworks": {
    "netcoreapp1.1": {
      "imports": [
        "dotnet5.6",
        "portable-net45+win8"
      ]
    }
  },

おそらく私は私のプロジェクトで何かを見逃しているでしょう.jsonがアップグレードに必要でしたか?または、パッケージの1つがv1.1と連携していませんか?どんな助けもありがとうございます。

注:私が1.0に戻って変更すると、すべて正常に動作します。

受け入れられた回答

HenkMollemaのコメントとCoreチームの友人の助けを借りて私はこれを解決することができました。答えはこのgithubの問題を参照してください。

キーは、1.1.0を参照するよう提案されているように、すべてのパッケージを更新するか、または1.1.0の適切な更新パッケージバージョンを更新していました。上のgithubのリンクの表に、v1.1リリースで更新されたすべてのパッケージの適切な参照がリストされています。

また、 ここではv1.1 SDKとランタイムをインストールしました



Related

ライセンスを受けた: CC-BY-SA with attribution
所属していない Stack Overflow
このKBは合法ですか? はい、理由を学ぶ
ライセンスを受けた: CC-BY-SA with attribution
所属していない Stack Overflow
このKBは合法ですか? はい、理由を学ぶ