L'attuale framework di destinazione runtime non è compatibile con il progetto

asp.net-core entity-framework-core

Domanda

Sto tentando di eseguire una migrazione iniziale dopo l'aggiunta di Entity Framework 7 al mio progetto Asp.Net 5. Sto seguendo questa documentazione .

Nel mio project.json ho specificato:

  "commands": {
    "web": "Microsoft.AspNet.Server.Kestrel",
    "ef": "EntityFramework.Commands"
  },

  "frameworks": {
    "dnxcore50": { }
  }

Sto tentando di eseguire il seguente comando nella directory del progetto tramite un prompt dei comandi:

dnx ef migrations add MyFirstMigration

Ma ottengo il seguente errore:

System.InvalidOperationException: il framework di destinazione runtime corrente non è compatibile con ProjectName. L'attuale framework di destinazione del runtime: 'DNX, Version = v 4.5.1 (dnx451) Assicurati che il runtime corrisponda a un framework specificato in project.json.

La cosa strana è che il mio project.json sta sicuramente dnxcore50 mira dnxcore50 . Ho anche controllato in global.json :

{
  "projects": [ "src", "test" ],
  "sdk": {
    "version": "1.0.0-beta8",
    "architecture": "x86",
    "runtime": "coreclr"
  }
}

E il mio pacchetto dipende da tutte le referenze beta8:

  "dependencies": {
    "EntityFramework.Commands": "7.0.0-beta8",
    "EntityFramework.Core": "7.0.0-beta8",
    "EntityFramework.SqlServer": "7.0.0-beta8",
    "Hl7.Fhir.DSTU2": "0.90.2",
    "Microsoft.AspNet.Authentication.Cookies": "1.0.0-beta8",
    "Microsoft.AspNet.Authentication.OpenIdConnect": "1.0.0-beta8",
    "Microsoft.AspNet.Diagnostics": "1.0.0-beta8",
    "Microsoft.AspNet.IISPlatformHandler": "1.0.0-beta8",
    "Microsoft.AspNet.Mvc": "6.0.0-beta8",
    "Microsoft.AspNet.Mvc.TagHelpers": "6.0.0-beta8",
    "Microsoft.AspNet.Server.Kestrel": "1.0.0-beta8",
    "Microsoft.AspNet.StaticFiles": "1.0.0-beta8",
    "Microsoft.AspNet.Tooling.Razor": "1.0.0-beta8",
    "Microsoft.Dnx.Runtime": "1.0.0-beta8",
    "Microsoft.Framework.Configuration.Json": "1.0.0-beta8",
    "Microsoft.Framework.Configuration.UserSecrets": "1.0.0-beta8",
    "Microsoft.Framework.Logging": "1.0.0-beta8",
    "Microsoft.Framework.Logging.Console": "1.0.0-beta8",
    "Microsoft.Framework.Logging.Debug": "1.0.0-beta8",
    "Microsoft.VisualStudio.Web.BrowserLink.Loader": "14.0.0-beta8"
  }

Risposta accettata

È necessario aggiungere dnx451 ai framework supportati dal progetto o passare a una versione di .NET Core.

  "frameworks": {
    "dnxcore50": { },
    "dnx451": { }
  }

Oppure esegui:

dnvm install latest -r coreclr

o

dnvm use default -r coreclr



Autorizzato sotto: CC-BY-SA with attribution
Non affiliato con Stack Overflow
È legale questo KB? Sì, impara il perché
Autorizzato sotto: CC-BY-SA with attribution
Non affiliato con Stack Overflow
È legale questo KB? Sì, impara il perché