Erreur de nuget "La référence d'objet n'est pas définie sur une instance d'objet" lors de l'installation d'Entityframework 7 à partir de la console de Package Manager dans VS2015

entity-framework-core visual-studio-2015

Question

J'essaie de créer un exemple d'application utilisant EF7 et mvc 6 dans Visual Studio 2015 avant publication.

Lors de l'installation de EF7 et de MVC6 à l'aide de la console du gestionnaire de packages, cette erreur s'est produite.

 PM> Install-Package EntityFramework.Commands -Version 7.0.0-beta3 -Pre
 Attempting to gather dependencies information for package    
 'EntityFramework.Commands.7.0.0-beta3' with respect to project
 targeting '.NETFramework, Version=v4.5.3' Install-Package : Object
 reference not set to an instance of an object. At line:1 char:1
 + Install-Package EntityFramework.Commands -Version 7.0.0-beta3 -Pre
 + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
     + CategoryInfo          : NotSpecified: (:) [Install-Package], Exception
     + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PackageManagement.PowerShellCmdlets.InstallPackageCommand

Quelqu'un peut-il m'aider à résoudre ce problème ou bien je le fais bien?

Réponse acceptée

J'ai résolu ce problème en désactivant l'option " https://api.nuget.org/v3/ " à partir de la source du package. Pour ce faire, choisissez Outils> Gestionnaire de packages Nuget> Source du package.

Et l’autre chose que j’ai faite est d’ajouter la source du paquet myget " https://www.myget.org/F/aspnetvnext/api/v2/ "

Suivre les étapes Choisissez Outils> Gestionnaire de paquets Nuget> Source de paquet> Cliquez sur Ajouter en haut de la fenêtre et ajoutez la source de paquet myget.


Réponse populaire

J'ai eu un problème similaire dans Visual Studio 2015 Community Edition.

Création d'un simple projet ASP.NET MVC 5 par défaut hébergé sur Azure. Je travaillais sur le projet et lorsque j'ai essayé de charger l'interface graphique de NuGet, mais que j'ai continué à avoir l'erreur "Référence d'objet ...".

J'ai redémarré Visual Studio en mode Administrateur (Visual Studio cliqué avec le bouton droit de la souris et démarré en mode Administrateur), ce qui a résolu le problème.




Sous licence: CC-BY-SA with attribution
Non affilié à Stack Overflow
Est-ce KB légal? Oui, apprenez pourquoi
Sous licence: CC-BY-SA with attribution
Non affilié à Stack Overflow
Est-ce KB légal? Oui, apprenez pourquoi