Question

existe actuellement aucun moyen, comment communiquer avec la base de données PostgreSql, quand je veux utiliser ASP.NET vNext? Je cherche une solution, qui fonctionnera principalement sur Linux.

EF7 ne prend en charge que MS SQL, un SqlLite maintenant et Npgsql n'est pas porté pour ASP.NET vNext.

Merci

Réponse populaire

Au lieu de EF7, vous pouvez utiliser NHibernate avec Fluent NHibernate. Npgsql fonctionne également bien sous ASP.NET 5 (vNext) sous Linux. Voici un exemple complet d' application ASP.NET vNext avec NHibernate + PostgreSQL fonctionnant sur le serveur Ubuntu .



Sous licence: CC-BY-SA with attribution
Non affilié à Stack Overflow
Est-ce KB légal? Oui, apprenez pourquoi
Sous licence: CC-BY-SA with attribution
Non affilié à Stack Overflow
Est-ce KB légal? Oui, apprenez pourquoi