El marco de destino de tiempo de ejecución actual no es compatible con el proyecto

asp.net-core entity-framework-core

Pregunta

Estoy intentando realizar una migración inicial después de agregar Entity Framework 7 a mi proyecto Asp.Net 5. Estoy siguiendo esta documentación .

En mi project.json he especificado:

  "commands": {
    "web": "Microsoft.AspNet.Server.Kestrel",
    "ef": "EntityFramework.Commands"
  },

  "frameworks": {
    "dnxcore50": { }
  }

Estoy intentando ejecutar el siguiente comando en el directorio del proyecto a través de un símbolo del sistema:

dnx ef migrations add MyFirstMigration

Pero me sale el siguiente error:

System.InvalidOperationException: el marco de destino de tiempo de ejecución actual no es compatible con ProjectName. El marco de destino de tiempo de ejecución actual: 'DNX, Versión = v 4.5.1 (dnx451) Asegúrese de que el tiempo de ejecución coincida con un marco especificado en project.json.

Lo extraño es que mi project.json definitivamente está apuntando a dnxcore50 . También he comprobado en global.json :

{
  "projects": [ "src", "test" ],
  "sdk": {
    "version": "1.0.0-beta8",
    "architecture": "x86",
    "runtime": "coreclr"
  }
}

Y todas mis dependencias de paquetes hacen referencia a beta8:

  "dependencies": {
    "EntityFramework.Commands": "7.0.0-beta8",
    "EntityFramework.Core": "7.0.0-beta8",
    "EntityFramework.SqlServer": "7.0.0-beta8",
    "Hl7.Fhir.DSTU2": "0.90.2",
    "Microsoft.AspNet.Authentication.Cookies": "1.0.0-beta8",
    "Microsoft.AspNet.Authentication.OpenIdConnect": "1.0.0-beta8",
    "Microsoft.AspNet.Diagnostics": "1.0.0-beta8",
    "Microsoft.AspNet.IISPlatformHandler": "1.0.0-beta8",
    "Microsoft.AspNet.Mvc": "6.0.0-beta8",
    "Microsoft.AspNet.Mvc.TagHelpers": "6.0.0-beta8",
    "Microsoft.AspNet.Server.Kestrel": "1.0.0-beta8",
    "Microsoft.AspNet.StaticFiles": "1.0.0-beta8",
    "Microsoft.AspNet.Tooling.Razor": "1.0.0-beta8",
    "Microsoft.Dnx.Runtime": "1.0.0-beta8",
    "Microsoft.Framework.Configuration.Json": "1.0.0-beta8",
    "Microsoft.Framework.Configuration.UserSecrets": "1.0.0-beta8",
    "Microsoft.Framework.Logging": "1.0.0-beta8",
    "Microsoft.Framework.Logging.Console": "1.0.0-beta8",
    "Microsoft.Framework.Logging.Debug": "1.0.0-beta8",
    "Microsoft.VisualStudio.Web.BrowserLink.Loader": "14.0.0-beta8"
  }

Respuesta aceptada

dnx451 agregar dnx451 a los marcos compatibles de su proyecto o cambiar a una versión de .NET Core.

  "frameworks": {
    "dnxcore50": { },
    "dnx451": { }
  }

O corre:

dnvm install latest -r coreclr

o

dnvm use default -r coreclr




Licencia bajo: CC-BY-SA with attribution
No afiliado con Stack Overflow
¿Es esto KB legal? Sí, aprende por qué
Licencia bajo: CC-BY-SA with attribution
No afiliado con Stack Overflow
¿Es esto KB legal? Sí, aprende por qué